WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Miscellaneous

PHP Version Finder

— Add- On om WorldWideScripts.net

Abonneer u op onze feed om de hoogte te blijven!

Nieuw! Volg ons als u het wilt!


PHP Version Finder - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting

Volg me op Twitter Follow Me On G + Follow Me On CodeCanyon live demo

Demo - Non Database (kreupel)
Demo - Database (kreupel)
De demo's zijn kreupele! We hebben de echte versie van elke functie en uitbreiding roerei.

PHP Version Finder - bijgewerkt naar v 1.0.3c 2010/12/09

Vind welke versie van PHP-script nodig. Toen hem werd gevraagd welke versie van PHP is nodig om onze scripts uit te voeren hebben we niet een definitief antwoord. We hebben dit script om de PHP-versie te bepalen, en dan hebben we het naar een ander niveau door het zoeken naar verouderde functies. Maar we hebben niet stoppen juist op dat. We opgenomen PHP Extensions en taalconstructies. We noemden het bijna goed in, maar toen we vroegen ons af... hoeveel keer we gebruikten deze functies. Overmatig gebruik van dezelfde functie kan worden vernederende op de prestaties. Monitoring hoe vaak een functie wordt gebruikt kan helpen bepalen of een "User gecreëerde functie" kan worden gecreëerd om de code te verminderen en de prestaties.

opsporing

PHP Versie Finder tracks: 3044 PHP Functies, 2260 PHP Extensions, 23 taalconstructies, 19 alternatieve voorstellen, 7 Tips / Tricks / Notes. (Plus 69 Experimental, 20 Gedeprecieerde, 47 "svn" functies)
De code heeft GEEN volledig of functioneren te zijn. Het hoeft niet eens zinvol. Zolang het tussen <? Php en?> Zal worden geëvalueerd. Kreupele Demo - De demo is verlamd te voorkomen dat mensen gebruiken in plaats van te kopen.

Niet raden!

De waarheid wordt verteld - de meeste ontwikkelaars "ball-park 'welke versie van PHP is vereist door het oproepen van een paar" key "functies die ze gebruikt. Met PHP Version Finder kun je zeker weten wat PHP versie daadwerkelijk is verplicht!
Niet Guess! - Run PHP Version Finder op uw script om zeker te weten wat verions van PHP is vereist om uw script te bedienen!

afgekeurd Detection

PHP Versie Finder laat u weten of er functies die u gebruikt, zijn afgekeurd.
Afgekeurde Detection - Controleer uw scripts voor afgekeurde functies

twee versies

De PHP Version Finder heeft geen database nodig. Echter, voor degenen onder u die liever een database zou gebruiken, het script bevat wel een database-versie.
Optionhal Database - PHP-versie vinder heeft geen database nodig, echter, een alternatieve versie wordt geleverd voor degenen die willen een database te gebruiken.
Waarom twee versies?
Het komt allemaal neer op nummers. Als er veel PHP-functies, de NON-database versie is sneller. Als er slechts enkele functies, database versie sneller. Hoeveel sneller? Nou, het is gemeten in micro seconden. Dus niet echt merkbaar. Nadat we de versie van de database hebben we besloten het was niet de moeite waard als de prestaties merkbaar anders was het niet. We besloten op te nemen, want het was al gebouwd - een weggevertje als je wilt.

Installatie

De installatie is eenvoudig. Upload de map, twee instellingen bewerken en je bent klaar.
Installion - Upload 1 directory naar uw server, bewerk een config bestand en je bent klaar om te gaan!

ingangen

U kunt een bestand uploaden vanaf uw computer, een bestand of gehele map op de server, of pasta code te scannen in een doos voor de verwerking.
Meerdere Ingangen - U kunt een bestand uploaden, scannen van een directory of kijk een blok code.

alternatieve voorstellen

Als PHP Version Finder vindt functies die worden afgekeurd, zal het u alternatieve suggesties die de verouderde functie kunnen vervangen geven.
Alternatieve Suggesties - U kunt uw script maken Bijvoorbeeld:
als je file_put_contents gebruiken (die PHP 5 vereist), zal PHP Versie Finder u te laten weten dat u fwrite plaats kon gebruiken die de vereiste versie zou kunnen verlagen tot in PHP 4. Niet alleen dat, maar er is een notitie bij file_put_contents dat je laat zien de code te gebruiken file_put_contents backwards compatible te maken.

Koop nu PHP Versie Finder!

Make Life Easy! Vind verouderde functies, krijg backwards compatible suggesties en weten welke versie van PHP is vereist om uw scripts
Schaf nu - leven gemakkelijk te maken, vindt afgekeurde functies, krijg achterwaarts compatibel suggesties en weten welke versie van PHP is vereist om uw scripts uit te voeren.

Huidige functies (v 1.0.0) - 2010/12/01

  • optioneel Database
  • afgekeurd Detection
  • Bestanden uploaden Processing
  • directory Processing
  • Geplakt Code Processing
  • AutoAanvullen
  • syntax Highlighter
  • 3044 PHP Functies
  • 2260 PHP Extensions
  • 23 taalconstructies
  • 19 Alternatieve suggesties
  • 7 Tips / Tricks / Notes
  • Plus 69 Experimentele Functies
  • Plus 20 Verouderd Functies
  • Plus 47 "svn" / unknown Functions

Update-v 1.0.1 2010/12/03

  • Vaste Kennisgeving Waarschuwingen
  • Fixed "Undefined Variabelen" Fouten
  • Vaste spelfouten
  • Bijgewerkt Help-bestand om wijzigingen te weerspiegelen
  • Toegevoegd Licensing Toelichting
  • Het opruimen van de "Report File"

Update-v 1.0.2 2010/12/04

  • Vaste Kennisgeving Waarschuwingen
  • Fixed "Undefined Variabelen" Fouten
  • Bijgewerkt Help-bestand om wijzigingen te weerspiegelen

Update-v 1.0.3c 2010/12/09

  • Opgeruimd code
  • Herschreef hoe statistieken worden geteld.
  • Herschreef het "Rapport File"

Downloaden
Andere onderdelen in deze categorieAlle onderdelen van deze auteur
OpmerkingenVeelgestelde vragen en antwoorden

Eigenschappen

Gemaakt:
3 december 10

Laatste update:
10 december 10

Hoge resolutie:
Nee

compatibele Browsers:
IE7, IE8, Safari, Opera

files inbegrepen:
JavaScript JS, HTML, CSS, PHP, SQL

Software versie:
PHP 4.x, PHP 5.x, PHP 5,0-5,2, PHP 5.3, MySQL 5.x

Trefwoorden

eCommerce, eCommerce, Alle spullen, deprecated waarschuwing, php-versie, syntax highlighting